TWD FDA Gateway - Delayed ACK Processing

Incident Report for Honeywell

Update

We are continuing to monitor for any further issues.
Posted Sep 23, 2026 - 18:10 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 23, 2026 - 13:06 EDT

Investigating

We are currently experiencing delays in ACK processing, which is impacting the normal processing rate. Our team is actively monitoring the situation and will continue to provide regular status updates.
Posted Sep 23, 2026 - 11:56 EDT
This incident affects: US Region - Production Environment (TrackWise Digital FDA Gateway).