SF Update : The Salesforce Technology team has observed that instance stability and performance are now at expected levels and declared the incident resolved
Posted Sep 16, 2026 - 15:26 EDT
Update
As per the latest update from Salesforce, the mitigation has now been deployed across nearly all affected instances. Their team is currently completing targeted restarts and manual recovery actions on the remaining impacted instances.
If you are still experiencing issues accessing TWD, please try clearing your browser cache and restarting your session. If the issue persists, please reach out to the Customer Support team for further assistance.
Posted Sep 16, 2026 - 12:30 EDT
Update
We are continuing to monitor for any further issues.
Posted Sep 16, 2026 - 12:25 EDT
Update
Latest update from SF: The rollout is progressing region-wise and services are returning to normal in regions that are completed. We're monitoring the rollout as it continues, and we're working on a permanent fix.
Posted Sep 16, 2026 - 10:27 EDT
Update
We are continuing to monitor for any further issues.
Posted Sep 16, 2026 - 10:26 EDT
Update
SF update: We've determined that the rollout didn't fully complete for a number of instances, so some customers may still be experiencing the original issue. We're reapplying the fix now. Some customers may need to clear cached data or restart their session for full recovery.
Posted Sep 16, 2026 - 09:26 EDT
Update
We are continuing to monitor for any further issues.
Posted Sep 16, 2026 - 09:25 EDT
Update
SF update :The rollout is progressing region-wise and services are returning to normal in regions that are completed. We're monitoring the rollout as it continues, and we're working on a permanent fix.
Posted Sep 16, 2026 - 08:25 EDT
Update
We are continuing to monitor for any further issues.
Posted Sep 16, 2026 - 08:25 EDT
Monitoring
SF update : A fleetwide rollout is in progress and customers are starting to see their service return to normal. In parallel, we're working on a code-level permanent fix.
Posted Sep 16, 2026 - 07:26 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 16, 2026 - 07:26 EDT
Update
Salesforce validated the fix successfully on the test instance. They will now roll out the fix fleetwide to all impacted instances.
Posted Sep 16, 2026 - 06:59 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 16, 2026 - 06:59 EDT
Update
New Update from SF : One of our core system components experienced increased load, which limited its capacity to process requests. We're working on a fix to resolve this issue and restore services.
Posted Sep 16, 2026 - 06:32 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 16, 2026 - 06:31 EDT
Identified
Latest update from Salesforce : We've attempted a rolling restart on one of the impacted instances to see if that resolves the issue.
Posted Sep 16, 2026 - 05:47 EDT
Update
We are continuing to investigate this issue.
Posted Sep 16, 2026 - 05:44 EDT
Investigating
Salesforce Investigations indicate that requests are stalling while waiting on a response from an internal login service, which is using up available server resources. Customers continue to experience severe delays, intermittent errors, and inability to access some services
Posted Sep 16, 2026 - 05:22 EDT
This incident affected: US Region - Production Environment (TrackWise Digital), US Region - UAT Environment (TrackWise Digital), EU Region - Production Environment (TrackWise Digital), EU Region - UAT Environment (TrackWise Digital), CA Region - Production Environment (TrackWise Digital), CA Region - UAT Environment (TrackWise Digital), and US Region - Beta Environment (TrackWise Digital).