Microsoft 365 email deliverability issue affecting notification from Trackwise Digital

Incident Report for Honeywell

Resolved

This Incident has been resolved.
Posted Jan 23, 2026 - 07:44 EST

Monitoring

Due to an ongoing issue with Microsoft affecting email deliverability, you may experience difficulties receiving emails from Trackwise Digital. Please note that this issue is not with Trackwise Digital itself, for assistance, contact your internal IT team.

You can review the Microsoft service status here for reference and Updates
https://status.cloud.microsoft/
Posted Jan 22, 2026 - 19:21 EST
This incident affected: US Region - Production Environment (TrackWise Digital).