Trackwise Digital Salesforce service disruption incident (Delayed Email Delivery)

Incident Report for Honeywell

Resolved

Salesforce has confirmed that the issue affecting outbound email delivery to recipients using a third-party email provider was resolved at 16:35 UTC. The third-party provider completed its mitigation activities, and Salesforce reports that no additional email delivery delays have been observed since that time.

Emails that were previously delayed are expected to continue processing through Salesforce's automated retry mechanisms until delivery is completed.

https://status.salesforce.com/incidents/20004405
Posted Sep 04, 2026 - 15:16 EDT

Update

Customers may continue to experience delayed outbound email delivery. Salesforce has indicated that impacted emails are delayed, not lost, and delivery attempts will continue to be retried for up to 24 hours.

Honeywell is actively monitoring Salesforce communications regarding this incident and will provide additional updates as more information becomes available.

Impact: Potential delays in email notifications, workflow emails, and other outbound communications sent through Salesforce.

https://status.salesforce.com/incidents/20004405
Posted Sep 04, 2026 - 13:34 EDT

Identified

There’s a Salesforce service disruption. During a service disruption, Emails are sent successfully from Salesforce; however, recipients aren't receiving the email and the mail server is returning a server busy error. Salesforce is investigating the issue and reviewing diagnostic data to identify the trigger.

We'll provide an update in 2 hours or sooner if additional information becomes available.

For more details refer : SF Service Disruption https://status.salesforce.com/incidents/20004405)
Posted Sep 04, 2026 - 11:29 EDT
This incident affected: US Region - Production Environment (TrackWise Digital), US Region - UAT Environment (TrackWise Digital), EU Region - Production Environment (TrackWise Digital), and EU Region - UAT Environment (TrackWise Digital).