TWD DMS - Service Disruption - EU Region

Incident Report for Honeywell

Resolved

This incident has been resolved.
Posted Nov 30, 2025 - 20:17 EST

Update

Ongoing monitoring is reflecting stability. We will hold in this state for the next hour.
Posted Nov 30, 2025 - 19:40 EST

Update

Monitoring has surfaced additional issues. We're pushing a change to stabilize rendition processing.
Posted Nov 30, 2025 - 17:45 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 30, 2025 - 10:58 EST

Update

Update - we're working on solution
Posted Nov 30, 2025 - 09:39 EST

Identified

The issues is identified. We're focused on resolution.
Posted Nov 30, 2025 - 08:27 EST

Investigating

We are currently investigating this issue.
Posted Nov 30, 2025 - 07:54 EST
This incident affected: EU Region - Production Environment (TrackWise Digital).