Delay in receiving ACK3 from the FDA

Incident Report for Honeywell

Resolved

Pending ACK3 has been received from FDA and processed successfully.
Posted Jun 20, 2025 - 07:52 EDT

Monitoring

Support teams are monitoring the situation for any new ACK3 delays.
Posted Jun 20, 2025 - 07:10 EDT

Investigating

We are observing processing delays and delays in receiving ACK3 from the FDA. Impacted records have initial submission times starting 6pm eastern time, June 18th. This does not appear to impact processing or return of ACK1 or ACK2. We are working with CDRH to get status updates from them and will update this page when additional information is available.
Posted Jun 19, 2025 - 17:17 EDT
This incident affected: US Region - Production Environment (TrackWise Digital FDA Gateway).